Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Albums Search Today's Posts Mark Forums Read FAQ
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine Sponsored by
J&D Corvette

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Reply
 
Thread Tools Search this Thread
Old 06-15-2003, 12:17 PM   #1
SPQQKY ZR1
Junior Member
 
SPQQKY ZR1's Avatar
 
Member Since: Nov 2002
Location: Bowie Md
Send a message via ICQ to SPQQKY ZR1
Default Temperature Control/1990ZR1


Need some help from you guys.. Yesterday started the ZR1 and fan motor came on high speed. None of the buttons are working and the fan is blowing out hot air. Not good on a 85 degree day. LED shows - - - with no outside air temp. Any ideas??
Thanks Bob
SPQQKY ZR1 is offline   Reply With Quote
Old 06-15-2003, 12:17 PM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page Temperature Control/1990ZR1
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 04:16 PM.


Emails & Password Backup